OtsAV DJ Pro Crashing Regularly

To many ads? Support ODJT and see no ads!

Proformance

DJ Extraordinaire
Nov 6, 2006
6,689
3,992
I've been having problems with OTSAV crashing on a regular and frequent basis. It occurs with both the older and newer update.

I've tried a number of things but it still just isn't reliable enough to run in a critical application.

Here's what's happeneing: At some point the next track will start prematurely and they will both lock-up into a stutter. Windows then detects an error and the system closes OtsAV and initiates a re-boot.

I do not have this probelm when running other applications on this machine, the system crashes only while running OtsAV.

The computer is a Dell Inspiron 1720, Vista SP3, and has 4G ram. Program is on internal drive C: and music is on an external independently powered USB drive. The problem occurs regardless of whether playing audio or video.

Any ideas?
 

Jumpin' Jeff

DJ Extraordinaire
Nov 10, 2006
521
65
55
East Central Iowa! (Independence)
The only problem I am aware of that ever caused Ots to crash was the recent Pause directive being executed in version 1.85.073, fixed in 074 within a couple days.

Personally, I suspect its a hardware problem, as Ots digs deeper into your system than most apps do, and this is the only occurance I know of.

For addional info, what was your Ots settings???? ABM on or off, automix or manual, Video?
 

nextgen1

DJ Extraordinaire
Sep 23, 2006
3,178
784
58
Waterford, CA.
www.tngdj.com
Running OTSAV on 2 laptops that are Vista 32 bit and they run flawless. Jeff is usually the man when it comes to OTS and by the way the new upgrade is great Jeff. It went live last night and worked flawless. The new branding thing was great. It was cool seeing my logo on the videos last night. It will be toned down a little tonight I have a wedding. Last night was a corp for a great group of people.
 

Proformance

DJ Extraordinaire
Nov 6, 2006
6,689
3,992
The issue has been occuring now for some time, but I'm not certain it was always there.

ABM is off, auto-dj on, Denon 4500 as controller and sound card, old school mode, running audio or video makes no difference. I have also seen it crash even while it was just sitting idle and playing nothing.

Last week it crashed 4 times during an event. Fortunately I'm still running this alongside my CD system, so I'm always prapred and it's not always live when it crashes. But the week before was a corporate theatrical presentation and it became so unstable just an hour before doors open I had to scrap it altogether and use another computer and program for all the A/V cues.

Now that I think of it, this Ots issue may coincide with another oddity. I can no longer connect to the internet via wireless. Even in my own office I get only "local access" to my network. I used to be able to log-on to hotel wi-fi if I needed to download a song but my wi-fi will no longer accept anything but a local connection. I've tried numerous fixes nad setting changes but nothing will restore my ability to connect.

Something has changed and Vista is probably the culprit, but the OS does so many things in the background without permission or notification it's infuriating. (Worst computer product I have ever encountered.)

I'm thinking about wiping the systen clean and installing XP.
 

SoftJock Rick

Industry Icon
Dec 29, 2006
25,213
2,399
WitSec
www.softjock.com
Something has changed and Vista is probably the culprit, but the OS does so many things in the background without permission or notification it's infuriating. (Worst computer product I have ever encountered.)

I'm thinking about wiping the systen clean and installing XP.
Vista does not miraculously change itself in the background Bob -- users do that by installing other software, visiting the wrong websites, changing settings, etc... ;)

Perhaps in the future, you should make note of what you put on your computer, so you can trace back the difficulties that arise because of it...
 

Proformance

DJ Extraordinaire
Nov 6, 2006
6,689
3,992
Vista does not miraculously change itself in the background Bob -- users do that by installing other software, visiting the wrong websites, changing settings, etc... ;)

Perhaps in the future, you should make note of what you put on your computer, so you can trace back the difficulties that arise because of it...
You know that's not true. Vista is full of MS assumptions and automations that "miraculously" wreak havoc until you can track them all down and assassinate them one by one. Dell is also just as guilty of bloating the machines with junk-ware. By the time these retail machines reach the store shelves they are like little time bombs waiting to explode on your desktop.

The "local access only" issue has been a frequent bain of Vista users for some time. Search it out and you'll see just how common and non-user friendly it really is. Whatever changes Vista makes when a user first logs onto public wi-fi messes up the protocols in a way that shuts them out of their home and other internet connections and cannot be reversed using the typical network controls.

Anyway, Vista still sucks. I'll skip Windows 7 and wait until MS can develop a perfect 10.

Jeff,
Thanks for the suggestion. I'll look into the controller firmware. Also, could my graphics chipset (Intel 965) or another component be overheating? I do not detect any unusual heat when he machine crashes, but someone suggested I may need to replace the perforated vent panels it sits on with a fan panel instead.

I ran audio only tonight without video enabled and went 5 hours with no crash. I'm going to try some more tests in the office this week.
 
G

Guest

Guest
Rockit has been flawless on every system i have tried it on!
 

DjDennis

RIP- My Dad (2011), Sister (2013) and Mum (2017)
well when buying a system get rid of everything that you dont need on it

decrapifier is the way to go - it cleans all the crap out and leaves the good things alone
 

Proformance

DJ Extraordinaire
Nov 6, 2006
6,689
3,992
Rockit has been flawless on every system i have tried it on!
I'm certain that it is, but it lacks the video power of OtsAV. I do a lot of audio-visual work so I need the presentation power and features that come with Ots.

I also prefer the music management of Ots to MP3 files. Media libraries are better managed as library materials and not simply file folders and directory trees.

I wish Ots was faster and smarter about where they put thier development effort (Auto-bpm mixing is a waste of programming talent - and the art-less time-fade mixes are remdial.) Yet, of all the programs out there it still holds the best promise and is the best fundamental conceptualization.

Of course, none of that helped the Sony Beta-max and I wonder sometimes if Ots will survive?
 

Jumpin' Jeff

DJ Extraordinaire
Nov 10, 2006
521
65
55
East Central Iowa! (Independence)
I have no experience with intel graphics.

One way to possibly find out is to run speedfan, and watch your system temps with and without video running.

Windows 7, Is a 10! (with UAC turned off...)
Windows XP IMO was a 7.
Vista wasn't a issue for me, unlike many others, including Dennis... ;)
I considered Vista an 8 personally.
 

Scott Hanna

DJ Extraordinaire
ODJT Supporter
Oct 25, 2006
6,866
8,344
54
Cleveland, OH
www.djincleveland.com
Ots runs flawlessly for me on

windows xp
Vista
windows 7

was working fine before the upgrade and working fine now.


Have you considered backing up your needed files and starting over with a recovery disc?

Is this the only computer you own? Have you tried it on a different computer?
 

Proformance

DJ Extraordinaire
Nov 6, 2006
6,689
3,992
Ots runs flawlessly for me on

windows xp
Vista
windows 7

was working fine before the upgrade and working fine now.


Have you considered backing up your needed files and starting over with a recovery disc?

Is this the only computer you own? Have you tried it on a different computer?
I ran it for audio on another machine, but have moved to this one in order to do video. Because I only recently started using the video in full force I can't really determine if the issue is inherent in the hardware or because of a recent software or configuration kink.

I am getting a better response with the recent Ots upgrade, but last time out I only ran audio and never activated the video overlay. (no crash)

Do your machines have a separate video card with it's own memory? My current machines chipset shares the main 3 gig of RAM with the system

I'm also going to try a full on video test using a high volume fan panel under the laptop to see if better cooling will make any difference.

Trying to avoid a full recovery because I'm pleased with some of the other tools I have on the machine.

Also looking at eliminating other media player/centers like WMP, Roxio, etc which may be trying to make background access to things that trip up Ots.
 

Scott Hanna

DJ Extraordinaire
ODJT Supporter
Oct 25, 2006
6,866
8,344
54
Cleveland, OH
www.djincleveland.com
I ran it for audio on another machine, but have moved to this one in order to do video. Because I only recently started using the video in full force I can't really determine if the issue is inherent in the hardware or because of a recent software or configuration kink.

I am getting a better response with the recent Ots upgrade, but last time out I only ran audio and never activated the video overlay. (no crash)

Do your machines have a separate video card with it's own memory? My current machines chipset shares the main 3 gig of RAM with the system

I'm also going to try a full on video test using a high volume fan panel under the laptop to see if better cooling will make any difference.

Trying to avoid a full recovery because I'm pleased with some of the other tools I have on the machine.

Also looking at eliminating other media player/centers like WMP, Roxio, etc which may be trying to make background access to things that trip up Ots.
None of mine have separate video memory that I know of. I don't run video either.
 

DjDennis

RIP- My Dad (2011), Sister (2013) and Mum (2017)
in winxp your dxdiag can tell you that DirectX is v9.0c in win7 they are on DirectX v11

so maybe thats one problem if your using software that isnt wanting DirectX 11